【技术文章】 QQ执行加群,无需打开网页

  • 【技术文章】 QQ执行加群,无需打开网页已关闭评论
  • 663
  • A+
所属分类:易语言

非原创,转载

介绍:现在基本用的都是postQQ群页面来得到TX的群加密代码的,现在这个是通过计算,计算出来群代码的。

代码区:

.版本 2
.支持库 spec
.支持库 eAPI

.子程序 执行加群
.参数 欲加入QQ群, 文本型
.参数 欲执行QQ号, 文本型, 可空
.局部变量 预定文本, 文本型
.局部变量 临时文本, 文本型
.局部变量 最终文本, 文本型
.局部变量 循环次数, 整数型
.局部变量 文本长度, 整数型

预定文本 = “{” + #引号 + “groupUin” + #引号 + “:” + 欲加入QQ群 + “}”  ' {"ExtParam":{"appId": "21"},"groupUin":' + g + ',"visitor":1}
文本长度 = 取文本长度 (预定文本)
循环次数 = 1
.判断循环首 (文本长度 ≥ 循环次数)
临时文本 = 取十六进制文本 (取代码 (预定文本, 循环次数))
循环次数 = 循环次数 + 1
.判断循环首 (取文本长度 (临时文本) < 2)
最终文本 = 最终文本 + 临时文本
临时文本 = “0” + 临时文本
.判断循环尾 ()
最终文本 = 最终文本 + 临时文本
.判断循环尾 ()
调试输出 (最终文本)
打开指定网址 (“tencent://groupwpa/?subcmd=all&param=” + 到大写 (最终文本) + “&fuin=” + 欲执行QQ号)

 

温馨提示:本代码来源于精易论坛,点击跳转

 

weinxin
微信公众号
更多文章请关注我的微信公众号
ClownSir